Client and Database Version

Access to LMS if Versions Mismatch [9363]
In a Client/Server environment, if all of the Clients were not updated by the organization’s IT department, the LMS could still be accessed by the end-user. This could cause error messages and potential data corruption due to the mismatch in the Client Version and Database Version. In this version, the Client and Database version must match in order for the end-user to access the software. An ini entry was added to skip version checking.

SKIPVERCHK=TRUE

Auto-Update of Clients [5291]
In the event that a client version and database version do not match, the user will be prompted to update the client, if the update .msi exits in the Suntell BE folder (either x64 or x86 based on operating system type). 18.2.0.0 must be in place as a minimum installed version, so this will be effective with the subsequent release.

This will only work if the user that launches the LMS is an administrator on his/her local machine.

Database Update

Allow BE Update from Client [9369]
The back-end update can now be applied from a client machine. This included moving the update of RMA data to the back-end update.

Spreads

Backup Spreads Folder [9368]
A backup of the spreads folder will now be made during update.

Creation of Spreads Folder [9367]
If the spreads directory was not accessible from a client machine when clicking on the Credit Analysis slider, the user was prompted to create a spreads directory. This was problematic as often it was created locally rather than in a shared environment. The ability to create a spreads user from a client machine has been removed. Instead, the user will receive a prompt that the spreads folder is not accessible and to contact the Suntell Administrator.

Component One Update

The controls that the LMS uses for various forms and reports, called Component One, has been updated to the latest version with this release.